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New Features in Wireless InSite 2.0 
 

 
This document describes changes and new features present in Wireless InSite 2.0, including: 

• New SBR based full 3D model 
• Automatically set Rx bounding boxes to reduce computation time 
• Calculation log window 
• Global Land Cover Characteristics (GLCC) Database 
• Biophysical foliage material 
• Layered dielectric material 
• Circularly polarized antennas 
• Urban Canyon Finite-difference time-domain (UCFDTD) propagation model  
• Moving Window Finite-difference time-domain (MWFDTD) propagation model  
• New waveform capabilities 
• 3D Antenna patterns in Project view 
• Rendering Tx/Rx antenna control vectors 
• Enhanced command line batch processing 
• Enhancements to diagnostic files 
• Raster-to-vector converter 
• Plot output vs. Tx-Rx distance for some types of receiver sets 

 
 
New SBR based full 3D model 
 
A number of changes have been made to the full 3D propagation model.  We have switched to 
entirely using an SBR (shooting and bouncing ray) approach to ray-tracing.  The previous 
versions used both the multiple image method and the SBR method.  However, it is also 
possible to only multiple image method by placing the character string “useSBR=no” in the long 
description of the study area. 
 
The new SBR model also constructs ray paths which propagate along a surface by multiple 
diffraction at facet edges.  The multiple image method will not include these ray types. 
 
 
Receiver bounding boxes 
 
The receiver bounding box is used to reduce the computation time for the ray tracing by 
grouping receiver points within larger bounding boxes, and first considering the intersections of 
rays with the bounding boxes before checking for the intersection of each ray with the small 
collection surfaces surrounding each receiver point.  The receiver bounding box is not a new 
feature, but some additional capabilities have been added to set the size of this box to obtain 
better reduction in the computation time.   
 
The bounding box should be used in most situations for all receiver set types except Points, 
Points-on-Face, and User-Defined Files, however, even in these latter cases it may be helpful to 
use bounding boxes if there are a large number of points in the set (> 25).  Use with user-
defined sets depends on how many points are contained in the file. 
 
Although this field is also active on the transmitter set advanced properties window, the 
bounding boxes are not used for transmitters at present, and this field can be ignored at this 
time. 
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Receiver bounding boxes properties can be set in the Receiver properties (Advanced) 
window.  To define a bounding box around a receiver set, first set Use bounding box to Yes.  
The size of the bounding box is set by the value entered in the Bounding box length field. 
 
At present the default size of the bounding box is 100 m.  This size was selected because it 
usually worked well for calculations in high-rise urban environments. Unfortunately, this size will 
not work well for smaller areas, and may even lead to longer run times than if the bounding 
boxes were not used at all. In the future we plan on adding an "automatic" checkbox to this field 
so that a good size can be set by the calculation engine.  As a temporary work around we 
suggest using the following rules of thumb: 
 

• For xy grid, vertical surface, polygon, circular cylinder set bounding box size to 10 times 
the spacing between points. 

• For linear routes and arc set the box size to 20 times the spacing 
• For points set the box size so that each one encloses roughly 25 points. 

 
It is also possible to have the size of the bounding box be set by the calculation engine by 
placing the text string useAutoBoundingBox=yes in either the project long description or the 
long description of a receiver set.  In the first case, the bounding box size will be set 
automatically for all receiver sets using bounding boxes, but in the latter case the bounding box 
size will only be set automatically for that specific receiver set.  The size of the bounding box will 
be written to the receiver section of the diag file. 
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Calculation log window 
 
The Calculation log window can now be viewed at any time by selecting View>Calculation log 
in the Main window.  This window records all information generated while performing 
simulations, including the time and date the calculation starts and finishes, as well as the 
elapsed time. 
 

 
 
Global Land Cover Characteristics (GLCC) Database 
 
Geo-referenced foliage information can be imported from data in the GLCC database, which is 
available for download at the Land Processes Distributed Active Archive Center (LPDAAC) 
http://edcdaac.usgs.gov/glcc/globe_int.asp.  This database has information on Seasonal Land 
Cover Regions (SLCR), which has a resolution of 1x1 km. 
 
To run the importer, select Project>Import>Foliage in the Main window and choose GLCC as 
the import option.  The imported foliage is modeled using the Biophysical material type, which 
is described below. 



 4

Biophysical foliage material 
 
The effective permittivity of a region containing foliage can be approximated by modeling the 
foliage as a dielectric slab containing randomly oriented leaves and branches which act to 
scatter and attenuate the propagating field.  The effective permittivity is determined from the 
biophysical characteristics of the tree, such as leaf area, leaf density, branch size, branch 
density, etc.  The Biophysical foliage material type also takes the permittivity of the leaves and 
branches into account when determining the effective permittivity of the foliage.  There is also 
an option for adjusting the effective permittivity to agree with a measured attenuation at a 
particular frequency, polarization and incidence angle. 
 

 
 
 
Layered dielectric material 
 
Wireless InSite now includes a layered dielectric material type which can be defined with an 
unlimited number of adjacent dielectric layers.  This material type replaces the “one-layer” and 
“two layer” material types.  Any materials defined using the discontinued material types will 
automatically be changed to the new type when the feature file is saved.  The old one and two 
layer definitions are also still recognized by the calculation engine.  Each dielectric layer is 
defined by its permittivity, conductivity, thickness, and roughness.  The first layer is the 
outermost layer, the second is the one below that, and so on.  The angle and frequency 
dependent reflection and transmission coefficients include the effects of interactions at the 
internal dielectric boundaries.  Only the roughness of the first layer is currently used in the 
calculations. 
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Circularly polarized antennas 
 
In addition to vertical and horizontal polarization, left-hand circular and right-hand circular 
polarization are now available for isotropic, omni-directional, directional, and helical antennas.  
Circularly polarized patterns can also be imported through Wireless InSite’s user-defined format 
by including the phase of the field components.  The file format is described in Chapter 7 of the 
user’s manual.  The effect of the circular polarization is calculated by means of the relative 
phase between the theta and phi components.  For a pure right-circularly polarized field, the 
phase of the phi component will exceed that of the theta component by 90 degrees, and theta 
will lead phi by 90 degrees for a pure left-hand circularly polarized field.  Circularly polarized 
patterns can also be imported from the far zone cuts generated by Remcom’s XFDTD software.  
The importation of XFDTD calculated pattern data is described in Chapter 7. 
 
 
Urban Canyon Finite-difference time-domain (UCFDTD) propagation model 
(licensed separately) 
 
The Urban Canyon FDTD model is intended for high-rise urban environments where the 
transmitting and receiving antennas are located close to the ground relative to the building 
heights.  For these situations the buildings can be approximated as being infinitely tall, and the 
interactions with the buildings are entirely determined by the 2D ground level perimeters, or 
footprints, of the buildings.  Urban Canyon FDTD simulates the radio wave propagation by using 
the finite-difference time-domain (FDTD) method to directly solve Maxwell’s equations after 
projecting the urban building layout onto a rectangular grid consisting of evenly spaced grid 
points in the x-y plane. 
 
 
Moving Window Finite-difference time-domain (MWFDTD) propagation model 
(licensed separately) 
 
The Moving Window FDTD model is a propagation model based on the 2-D finite-difference 
time-domain method.  Unlike the Urban Canyon FDTD model, the 2-D geometry is found from 
the intersection of the 3-D geometry with the vertical plane rather than the horizontal plane.  
This model is used to simulate the propagation of radio waves at UHF and VHF frequencies 
over irregular terrain. 
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Since we are typically interested in propagation over relatively long distances (thousands or 
tens of thousands of wavelength), the amount of computer memory and computation time 
needed to perform FDTD on the entire propagating path is prohibitive.  In MWFDTD, we take 
advantage of the fact that the propagating radio pulse is limited in spatial extent and create a 
computational grid only wide enough to include the pulse.  Then as the pulse propagates along 
the terrain, we move the computational mesh to follow along with the pulse so that the radio 
wave pulse is always within the computational grid.  In this way, we ensure that at each time 
step, we only calculate the field values in the area where field is nonzero.  The MWFDTD 
method is illustrated below. 
 

 
 
 
New waveform capabilities 
 
Two types of waveforms were allowed for in Wireless InSite v1.5.2 and earlier.  One type was 
called a “narrowband waveform” and the other was called a “wideband waveform”.  The terms 
referred to whether frequency dispersion was included in analysis.  The narrowband waveform 
did not include frequency dispersion in the analysis, but used a bandwidth parameter to account 
for some effects of having a finite width waveform.  The wideband waveform was limited to a 
frequency domain waveform specified through an external file produced by the user.   
 
The term wideband was used to refer to the ability to perform UTD calculations at multiple 
frequencies with carrier amplitudes specified in the user-defined file, and the ability to inverse 
Fourier transform the frequency domain results to create the time domain response.  Even when 
a wideband waveform was assigned to a transmitter, some output was still only evaluated at a 
single frequency. 
 
Wireless InSite 2.0 includes the following new waveform pulse shapes: Gaussian and Gaussian 
derivative pulses, Blackman, Hamming, Hanning, and Tukey time-domain envelopes, and 
raised-cosine and root raised-cosine pulses.  Previously defined narrowband waveforms are 
now labeled as sinusoidal waveforms.  The user defined waveform can now be specified as 
either a function of time or frequency.  The format of the file is described in Chapter 9 of the 
user’s manual. 
 
Each waveform type has its own properties window for setting the waveform parameters.  The 
parameters for each waveform are described in Chapter 9 of the user’s manual.  Plots of the 
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waveform in both the time- and frequency-domains are displayed on the right-hand side of the 
properties window.  Larger plots with the full set of graph properties are available through the 
context menu accessed by right-clicking on the waveform entry in either the main window or the 
project hierarchy window. 
 

 
 
The distinction between a wideband pulse and a narrowband pulse has been eliminated from 
the software.  Instead the user will be able to designate waveforms as being “dispersive” or 
“non-dispersive”.  The dispersive option is disabled for some waveform types.  Waveforms 
which use the sinusoid pulse shape are always non-dispersive, and waveforms using the 
Gaussian derivative pulse shape and user-defined waveforms are always dispersive. 
 
The calculation of some output types will depend on the dispersion setting but other output may 
not.  By selecting the dispersive option, the calculation of electric field versus time and power 
versus time include the effects of dispersion on the broadband waveform pulse as it propagates.  
The electric field is also calculated as a function of frequency.  The e-field vs. time, power vs. 
time (power delay spread) and e-field vs. frequency are only available for receiver sets of type 
points and points-on-face. 
 
The user-defined waveform was just assumed to give a real valued time domain pulse and no 
check was performed to make sure the waveform satisfied this requirement.  A check was 
performed on the frequency increment to make sure it was sufficiently small. 
 
The purpose of waveforms in Wireless InSite will be to allow the user to input parameters which 
describe the signal which is radiated from the transmitting antenna, and to act as a kind of 
bandpass filter at the receiver. 
 
Any output involving phase is inherently only meaningful at a single frequency.  Output types in 
this category include: Total Electric Field, Complex Electric Field, and Complex Impulse 
Response.  Even when a waveform is designated as dispersive, these output types will still be 
evaluated only at a single frequency.  The carrier frequency, or center frequency for a Gaussian 
derivative or user-defined waveform, will be used in these cases. 
 
The addition of dispersive calculations is also an important addition when used with UTD 
propagation models.  By selecting the Dispersive waveform option, the calculation of E-field 
versus time and power versus time include the effects of dispersion on the broadband waveform 
pulse as it propagates. 
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3D Antenna patterns in Project view 
 
To facilitate the orientation of transmitter or receiver antennas, the ability to view the rotated 
antenna pattern in the Project view is now possible as shown in the figure below.  The display of 
the antenna pattern is enabled for each transmitter or receiver set through the “Antenna viewing 
options” button in the transmitter or receiver properties window.  The antenna pattern display is 
disabled by default.  To avoid lengthy initial rendering time, all pattern displays will be turned off 
when a project is initially loaded. 
 

 

 
 
 
Rendering Tx/Rx antenna control vectors 
 
In addition to viewing the antenna pattern, the final orientation of the antenna after application of 
the Tx/Rx rotations can now be visualized through the display of a set of orthogonal control 
vectors rendered in the Project view.  All rotations applied to the antenna pattern are also 
applied to these vectors.  The figure above shows these vectors drawn for the directional 
antenna on the left.  The red dashed line is along the boresight of the antenna, and the blue 
vector shows the polarization along the boresight.  The antenna viewing options can be 
accessed through the “Antenna viewing options” button in the transmitter or receivers 
properties windows. 
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Enhanced command line batch processing 
 
It is also possible to run the calculation engine from a DOS window or as a batch job. Batch jobs 
can be accomplished by using the -batch option when running Wireless InSite from the 
command line.  Using quotes around the setup file is recommended.  An example command for 
a batch run is shown below. 
 

 
 
Enhancements to diagnostic files 
 
More diagnostic information is now written to the *.diag file during the calculation.  Additional 
files are also written to the diag folder when “diagnostic information” is a requested output type. 
 
Raster-to-vector converter 
 
Wireless InSite can now import city data in raster format and convert it to vector format for use 
with all propagation models.  By interpreting values in the raster data as heights, the raster-to-
vector converter can detect regions of similar height and form buildings by extruding these 
regions to the ground.  The file formats currently supported include ARC ASCIIGrid and 
Portable Gray Map (.PGM) raster images.  To import raster data select Project>Import>Raster 
data. 
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Plot output vs. Tx-Rx distance for some types of receiver sets 

 
In the past all line plots of output vs. distance, the distance was the accumulated distance in 
going from one receiver point to the next.  While this was a good way of displaying results along 
a receiver route or arc, it was not useful for xy grid receiver sets, or other receiver sets covering 
an area, such as cylinders, vertical surfaces and polygons.  For the latter set types we have 
changed the distance in the output file to be the transmitter to receiver distance.  The default 
line type for these plots is still “lines”, but this can be changed to “points” to create a more useful 
graph.  For receiver sets of type points, points-on-face, and user-defined sets, the distance is 
still the accumulated distance in going from one receiver point to the next. 


